Page 1 of 2 12 LastLast
Results 1 to 20 of 31
  1. #1
    Community Manager
    Cordovan's Avatar
    Join Date
    Nov 2010
    Posts
    31,821

    Default NVIDIA 64-bit Client Issue

    We are investigating an issue with machines running the 64-bit Beta DDO client on an NVidia graphics card. In the meantime we would like to pass along a workaround that should get your issue resolved for now. This corrects an issue where the launcher disappears when trying to enter a game world:


    1. Open Windows Search, Type: "Nvidia Control Panel", and run the result.
    2. Click "Manage 3D settings"
    3. Click the "Program Settings" tab
    4. Click the "Add" button
    5. In the add list, find dndclient64.exe (must have already tried to run 64bit DDO for it to appear)
    6. Select dndclient64.exe and click "Add Selected Program"
    7. Click the dropdown box under the new selection, and choose "High-performance NVIDIA processor"


    Please note that players can also switch back to the 32-bit client through the Options menu in the game launcher.

    Have fun, and don't forget to gather for buffs!
    Follow DDO on: Facebook Twitter YouTube
    Join us on Twitch!
    Hello from Standing Stone Games! Facebook Twitter
    For Support: https://help.standingstonegames.com



  2. #2
    Community Member Stoner81's Avatar
    Join Date
    Jul 2012
    Posts
    3,816

    Default

    My screen went from green and blue to mostly red after doing the above. x86 works just fine though so at least I can play

    Stoner81.

  3. #3
    Community Member blametroi's Avatar
    Join Date
    Nov 2009
    Posts
    479

    Default NVIDIA user here, did not need to do this

    Everything worked for me right from the get go. I pulled up the control panel and my default settings match what I see in the screen grab (eg, antialiasing) but I do not have a dropdown box to select a graphics card, my GTX 980 is the only enabled card in my system.

    I suspect all my defaults are "just right", perhaps by happy accident since I don't tweak these settings.

    Looking good for me, thanks for the effort you all put in to this.

  4. #4

    Default

    I had an issue with the 64bit client closing my launcher but this PC is an AMD CPU and integrated ATI graphics.

    I downloaded and installed the Directx 2010 runtime from MS so that Directx 10/11 in settings wasn't greyed out and I was able to select Directx 11.

    The 64 bit Client now works for me
    Former Mournlander - Jan 2012 - Jan 2014
    Players Council - 2015
    Cannith Server

  5. #5
    Founder & Super Hero Arkat's Avatar
    Join Date
    Feb 2006
    Posts
    10,610

    Default AMD Radeon User Here

    I choose to use the 64-bit client in the Options. Then I get to the Server choice screen and choose "Play."

    My client quits/disappears and never comes back.

    I have to switch back to 32-bit in order to play.

    A little more info here: https://www.ddo.com/forums/showthrea...=1#post6294973
    Last edited by Arkat; 02-12-2020 at 03:51 PM.
    "A wise person chooses the right road; a fool takes the wrong one." - Author unknown
    *13598*
    Quote Originally Posted by Lynnabel View Post
    Hi Welcome

  6. #6
    Community Member TorkRaider's Avatar
    Join Date
    Aug 2010
    Posts
    37

    Default This worked for me.

    Adding old DirectX drivers...

    I finally fixed the 64 bit client issue by downloading and running the Microsoft DirectX package found here... https://www.microsoft.com/en-us/down...ils.aspx?id=35. My newer Win10 Pro only had DirectX 12 installed and I guess that was OK for the 32 bit but bombed the new 64 bit client. Anyway once I installed the legacy 9/10/11 package everything worked. Hope this helps someone.

  7. #7

    Default

    It worked fine for me on my PC . . . then I tried it on the laptop, and the screen turned azure and I had to restart it to see a color other than blue. Very weird.

    Yeah, tried the workaround, tried downloading the directx package, updated the driver, still turns blue. No clue what the problem is, sorry.

    If it helps, it's a GeForce GTX 660M
    Last edited by PsychoBlonde; 02-12-2020 at 05:37 PM.
    Kimmeh--Lehren--Natheme--Arekkeh--Daiahn--Yesminde
    Join Magefire Cannon on Thelanis!
    Follow PB on Twitch!
    PB's Youtube Channel

  8. #8
    Community Member TorkRaider's Avatar
    Join Date
    Aug 2010
    Posts
    37

    Default

    I think there are at least 2 issues. 1) Client won't load because a lack of legacy drivers and 2) selecting default GPU required on some machines.

  9. #9
    Community Member Dj_Fisty's Avatar
    Join Date
    Mar 2010
    Posts
    178

    Default

    No Issues at all but i have my video drivers, and x64 .nets and redist DirectX june 2010 updated.

    I7 7700k @ 4.2GHZ
    16GB 3733MHZ ddr4
    M.2 500 GB
    Asus Rog Strix 2080 OC RTX Nvidia Updated drivers.

    *EDIT*

    After logging off, i tried to log back in and it kept minimizing the game......
    Restart fixed it.

    *Edit*

    Happens all the time now, Easy fix Hit escape key like mad when alt - tabing back in and it fixes it ROFL.
    Last edited by Dj_Fisty; 02-12-2020 at 07:21 PM. Reason: Hardware Listing

  10. #10
    Community Member Bolo_Grubb's Avatar
    Join Date
    Oct 2009
    Posts
    2,820

    Default

    if you are having trouble finding the 64 bit client try looking here C:\Program Files (x86)\StandingStoneGames\Dungeons & Dragons Online\x64

    or if you have an older install it might be in C:\Program Files (x86)\Turbine\Dungeons & Dragons Online\x64

    or if you installed through Steam it might be in C:\Program Files (x86)\Steam\steamapps\common\Dungeons and Dragons Online\x64

    In that x64 folder you should find a dndclient64.exe
    Last edited by Bolo_Grubb; 02-12-2020 at 06:51 PM.
    Kill'em all and let their favorite deity sort'em out
    BoloGrubb / DJGrubb / Gijo
    Proud member of the HighLords of Malkier

  11. #11
    Community Member CSQ's Avatar
    Join Date
    Jul 2009
    Posts
    758

    Default

    Quote Originally Posted by PsychoBlonde View Post
    It worked fine for me on my PC . . . then I tried it on the laptop, and the screen turned azure and I had to restart it to see a color other than blue. Very weird.

    Yeah, tried the workaround, tried downloading the directx package, updated the driver, still turns blue. No clue what the problem is, sorry.

    If it helps, it's a GeForce GTX 660M
    I have the same display issue, but on a RTX 2070 laptop. I have to use the 32-bit client, which is fine. I tried verifying the game files from the launcher, my graphics drivers are up to date, and it happened across several restarts. I can whip up a DXDiag and PM it to whoever needs if it would help. When the game "boots", it simply makes the screen time travel back to 4 bit colors (not always just blue, but one time it was just blue) and there doesn't seem to be any game launching. On the other hand, it does appear like Steam thinks the client has closed. Not sure if any of that info helps, but it can't hurt, right?
    I primarily play Zunzyne Siegemaker, and am the guild master of Ares Macrotechnology on Ghallanda.
    Reaper Experience Calculator: https://docs.google.com/spreadsheets...ewE/edit#gid=0 (out of date as of U42.4, needs testing for new values)

  12. #12

    Default

    Quote Originally Posted by Cordovan View Post
    We are investigating an issue with machines running the 64-bit Beta DDO client on an NVidia graphics card. In the meantime we would like to pass along a workaround that should get your issue resolved for now. This corrects an issue where the launcher disappears when trying to enter a game world:


    1. Open Windows Search, Type: "Nvidia Control Panel", and run the result.
    2. Click "Manage 3D settings"
    3. Click the "Program Settings" tab
    4. Click the "Add" button
    5. In the add list, find dndclient64.exe (must have already tried to run 64bit DDO for it to appear)
    6. Select dndclient64.exe and click "Add Selected Program"
    7. Click the dropdown box under the new selection, and choose "High-performance NVIDIA processor"


    Please note that players can also switch back to the 32-bit client through the Options menu in the game launcher.
    I don't have a file called "dndclient64.exe"

  13. #13

    Default

    Quote Originally Posted by TorkRaider View Post
    Adding old DirectX drivers...

    I finally fixed the 64 bit client issue by downloading and running the Microsoft DirectX package found here... https://www.microsoft.com/en-us/down...ils.aspx?id=35. My newer Win10 Pro only had DirectX 12 installed and I guess that was OK for the 32 bit but bombed the new 64 bit client. Anyway once I installed the legacy 9/10/11 package everything worked. Hope this helps someone.
    This got me halfway there.
    Before installing this DX pac I could only log in and then nothing happened.
    After installing this DX pac I could log in.
    but....it had the blue tint screen on everything

    logged in and switched from DX10 to DX9
    reboot laptop
    colors correct with DX9 in game

    now the desktop has the blue tint and the game colors are OK
    gotta reboot after playing to fix the desktop

    eh, it is beta after all
    Last edited by PuppiesAndRainbows; 02-12-2020 at 06:56 PM.

  14. #14
    Time Bandit
    ex DDO Players Council
    Natashaelle's Avatar
    Join Date
    Jul 2009
    Posts
    2,862

    Default

    No problem at this end -- desktop PC, AMD CPU, nVidia RTX 2080 Ti

  15. #15
    Hero
    Mmm... purple!
    PurpleTimb's Avatar
    Join Date
    Dec 2009
    Posts
    573

    Default

    Quote Originally Posted by TorkRaider View Post
    Adding old DirectX drivers...

    I finally fixed the 64 bit client issue by downloading and running the Microsoft DirectX package found here... https://www.microsoft.com/en-us/down...ils.aspx?id=35. My newer Win10 Pro only had DirectX 12 installed and I guess that was OK for the 32 bit but bombed the new 64 bit client. Anyway once I installed the legacy 9/10/11 package everything worked. Hope this helps someone.
    Thank you for this suggestion. The NVidia Control Panel did not help me, but adding the older DirectX drivers got my client working again.

  16. #16
    Community Member
    Join Date
    Mar 2006
    Posts
    7

    Default Thanks!

    Worked for me in 64bit without the tweaks, but thanks for getting a workaround out so quickly! I know many appreciate it!

  17. #17

    Default

    Ah, okay, that seems to have fixed it for my machine. I couldn't figure out how to do the workaround because nothing I was doing would get the dndclient64.exe to show up in the list, but then I saw that there was a Browse button and I was able to locate the application manually and do the workaround and it launched fine.

    So, if you do the workaround, click on the Browse button to go manually dig up the file, don't expect it to appear on the list of applications you can add.
    Kimmeh--Lehren--Natheme--Arekkeh--Daiahn--Yesminde
    Join Magefire Cannon on Thelanis!
    Follow PB on Twitch!
    PB's Youtube Channel

  18. #18
    Community Member
    Join Date
    Apr 2013
    Posts
    242

    Default a different nvidiia 64-bit issue?

    I have multiple (2) graphics cards and 2 screens with SLI disabled. When I run DDO the game always starts on my second screen rather than my main screen (i.e. screen 1).

    Update: in fact if i start windowed (which i have to do to move to the correct screen), if i change to full screen it shifts to the second monitor.
    Last edited by Anthorin1; 02-13-2020 at 01:46 PM.

  19. #19
    Community Member MasterKernel's Avatar
    Join Date
    Nov 2010
    Posts
    339

    Question Good job ?

    No issues here.

    But I failed to see any [in game] differences between x32 and x64.

  20. #20
    Community Member
    Join Date
    Nov 2010
    Posts
    64

    Default

    The fix worked on my laptop with a nvidia 1050GT.

    Haven't had the chance to try it on the pc wit a 660TI.

    Thanks for the fix.
    If you want to use a mic and headphones get a games machine.

    PC games are still for those who TYPE!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload