Download for update 60 stalling endlessly


New member
Hello. I've been able to continuously play DDO with no issues for a while now, and I log in every single day at -least- for Daily Dice if nothing else, but the recent update 60 has a problem. It goes as such:

The launcher launches,
It does the "applying forward iterations"
It then begins to -attempt- to download the actual 1000+ files but...
It stalls. And not in any way consistently, either. In fact, no two attempts have ever been exactly the same. For example...

Sometimes, it will download some X% of file 1, then stall for five seconds, then download a little more %, then stall again, this time for good...
Sometimes it will download straight to file 2, then stall there...
Sometimes on file 3...sometimes on file 4...
Sometimes it stalls on one file, then stutters its way through and -does- succeed in downloading that current file that it began stalling on, but then stalls for good on the next one.
One time, it went up as high as file 6.
And even when it does stall on the same file as one before, it never stalls in the exact same percentage, and the amount of stuttering before stalling for good is variable every time too.

As an exacerbating problem, the files that do download, don't stay downloaded. Every single time, the "...out of XXXX files" number remains exactly the same.

A couple years ago, I once had a similar problem with the MMO game, Guild Wars 2, when I first started playing that one. Every now and then after I began playing, when they would release a major update above a certain size rather than some small quick patch, I experienced a very similar stalling problem. It would start downloading, and then (because the GW2 launcher actually does show download speed), it shows my normal download speed rapidly tick downward from the normal rate down to double- or even single-digit kilobytes or bytes per second. The solution for -that- one was pretty jank; I had to go into my computer's own networking settings and had to add in a temporary manual rule that whenever attempting to connect to the patch server, that I would redirect and instead download from an alternative different patch server, and then it worked fine. Haven't experienced that problem with GW2 the after those first few times a couple years ago however.

So now update 60 for DDO is doing something awfully similar, though I don't know if it is the same, and I don't know if the solution is the same. Does anyone have any ideas?

I have not yet attempted to uninstall and reinstall DDO yet (which did not work for the similar GW2 issue back then), as I'd like to try other options first, though I can give that a shot if trying at least one other thing first doesn't work, though I don't anticipate results if I do.


Ha good luck! I would put in a ticket but they will problably ignore it like they did mine. Dont spam this post because they wont ignore that. They are around to enforce the rules but not around to help. dissapointting.


New member
Okay, so, I ended up getting very preoccupied in the past month, but, I do still need help on this, the problem still persists. The release of Vecna Unleashed after update 60 still has not solved the problem, the download of now greater-than-3000 files continues to stall in exactly the way described above.

I still have not attempted the "repair install" option nor the "uninstall completely and reinstall/redownload" option, on the simple fact that the "repair" option said it would have to redownload 14 gigs worth of files. This is a problem for me because my net downloads at a rate of roughly 1 gig an hour. And while I thought that the DDO launcher downloading every file individually meant, or at least used to mean, that any downloaded files stay downloaded, that no longer seems to be the case for at least update 60-onwards specifically. Without someone being able to assure me that if I try to redownload from scratch, any downloaded files will STAY downloaded so I can stop and resume the download as needed and not have any problems with disconnects in the middle, then I cannot safely go for either of these options. I could've sworn that the launcher, when downloading files and having to stop halfway through, would save the files already downloaded and not have to start over, I need someone to assure me that this will still happen if I try to repair/reinstall from scratch, and that update 60-onwards they their lonesome are just weird and won't be a problem in the redownload.

Is there anyone out there who is having a similar problem to me? Is there anyone out there who has heard of a similar problem in any other games? I have tried searching on the internet for more advice, but haven't turned up any luck so far.


New member
!!! Well, I tried firing up the launcher just today for the heck of it -- the total files to download have grown from 3300 to 4500 -- and, for no apparent reason at worked! I haven't done anything, I haven't changed anything, it just went and worked all on its own. All the files downloaded without stalling out, and the game runs again.

...Still wish I knew why, and could document it for anyone else who might have the problem in the future, but oh well. At least it works again. Inexplicably, but it works.

EDIT: Speaking of documenting for the future...where did all the posts go from before the forum upgrade? Those got transferred along, or at the very least archived somewhere, right? ....right?


New member
I hav the same problem from July as u. :cry: I think its more convenience if we can directly download updated game files from some cloud disk.