Dryad Grove: Defenseless - Eveningstar Challenge - BUG - can not complete

Propane

Member
Hello!

Tried running this challenge this weekend (want to roll the dice on some throwing daggers...) - we could run the quest - but at time completion - it wouldn't end the quest...
Looking at the XP report / quest objective - sting table error -
Anyone else see this?
 

rabidfox

The People's Champion
Force quit (or just tab out - launching the same account a 2nd time will quit out the original game) and log in again. And your instance will still be going; it follows the same instance despawn rules (of 5min?) as anything else even when solo. It's a silly method to get the completion to tick off, but it's what seems to work for a bunch of those challenges when they bug out.
 

Ying

5000+ hours played
Yeah for whatever reason, the ES challenges sometimes get stuck like this. Sardonic's solution has worked for me several times in the past.
 

Blerkington

Well-known member
There are still problems with these. Of the three I tried today, two failed to complete. I hadn't seen this thread at the time so wasn't aware of the problem and the work-around.

So since this thread exists presumably SSG is aware of this problem. Maybe the devs could consider posting a warning, closing the challenges or fixing this promptly? It's situations like this which prove again and again how little respect for players' time the people who work at this company have.

Thanks to the OP and Rabid for letting the community know about the problem and solution. Bug report submitted for all the good it will do.
 
Top