Game still playable for me since U59

Prior to U59 I was able to play the game with very little lack, outside of specific lag spikes.

However, since the post U59 patch, the game has been literally unplayable. My guildies have stopped playing as a result. I keep coming back to test it out, but suffer constant rubber banding (every 5 seconds or so), regardless of the time of day, server or character. I've updated drivers, tried 32-bit and 64-bit, and various dx modes (dx9 through to 11). I've also disabled the Geforce experience overlay which I can see from the forums has worked for at least one other person.

Processor: 11th Gen Intel(R) Core(TM) i9-11900KF @ 3.50GHz 3.50 GHz
Installed RAM: 32.0 GB (31.9 GB usable)
Graphics Card: NVIDIA GeForce RTX 3060

I'm not technical, so may have missed something obvious. If anyone can offer any suggestions that would be great? Alternatively, could there be something in my system that is no longer compatible with DDO?


Well-known member
Check DDO video settings under Options Advanced Graphics..


Shadows and Post Processing
  • Video Post Effects
    • Affects overall video quality, including lighting, bloom, shadows, and sunlight
    • May have a significant impact on performance, especially in certain quests or rooms

"May have a significant impact on performance" In other words.. Laagggg
Last edited:
Thanks. That was a good thought.
I disabled those effects and tried turning others down, but sadly no impact on the constant lag.


Well-known member
Rubberbanding is typically network-related.

Check your antivirus/firewall to see if DDO is getting through them OK.

If you have a VPN, check that.

If you have a router, powercycle it and/or check your settings there. You can also try a direct line from your modem to your PC, bypassing the router (which is a faster test to see if something with the router is the culprit).

Hard reset your modem. Unplug it for 30+ seconds and plug it back in. Or unplug it for several hours and see if your ISP will give you a new IP when you finally plug it back in.