If you encountered a VIP subscription issue with an expansion purchase please post up your ticket number here

Status
Not open for further replies.
VIP and did not purchase the expansion (or anything else recently). My VIP subscription was on autorenew but the account information was down graded to premium. However, bar one single glorious lag free fortnight which finished @5 days ago, the game has been literally unplayable due to rubber banding 'every' 5 seconds since the lag 'fix' patch (or more precisely the patch to fix 32bit running). So my question have my VIP subscription and payments actually been cancelled?
 
We are working to resolve reports that some players have experienced a loss of their VIP subscription benefit after making a purchase of an expansion, and we need some specific cases to help us investigate.

If you ran into this issue after making an expansion purchase, please make sure you have a ticket in with Customer Support and then post your ticket number in this thread as a reply below.


We need to associate these forum reports with game accounts through our help system. Thanks!
The issue with the store is it is not storing the 3-digit code on the back of the card in the new store. Everything else is working. I had an issue last month when I renewed my VIP but was aware of the issue and did not put in a ticket to get it fixed. this was not an issue in the old store. Everything was stored properly. I deleted an old card and input the new one into the new system but it seems there is a disconnect in storing that 3-digit security code. the old system did not have that issue

Good luck on fixing it

ChiefVisigoth
 

dur

aka Cybersquirt
Still no response or update or anything.
Have you tried checking the Hall of Heroes vendor, uh... don't remember his name.. :(

And yeah, they only respond via email for the really tricky ones. Didn't used to be that way, but, Que sera, sera, I guess. :confused:
 
Last edited:

dur

aka Cybersquirt
VIP and did not purchase the expansion (or anything else recently). My VIP subscription was on autorenew but the account information was down graded to premium. However, bar one single glorious lag free fortnight which finished @5 days ago, the game has been literally unplayable due to rubber banding 'every' 5 seconds since the lag 'fix' patch (or more precisely the patch to fix 32bit running). So my question have my VIP subscription and payments actually been cancelled?
So glad (?) mine auto-renewed before the kerfuffle.. this has happened before, a long time ago, and in a different way.. tends to happen when you change vendors.
 

dur

aka Cybersquirt
Have you tried checking the Hall of Heroes vendor, uh... don't remember his name.. :(

And yeah, they only respond via email for the really tricky ones. Didn't used to be that way, but, Que sera, sera, I guess. :confused:
Anyone remember the 'good old days' when you could CALL someone? Que sera, sear sera...
 

_fully_carroted_

Active member
Not sure if this is still happening - but I just got hit with it. Ticket number 324410.

I have an active VIP subscription, bought DDO points and my VIP status was immediately broken. Can't use the shared bank, can't port to eveningstar, etc.

It's blocking me from playing this weekend because I need to move items around!
 

Kathwynn

Well-known member
No 500 ddo points again this month. Put in a ticket again. Got a reply that said they were aware of the problem and that the ticket is on hold. SMH
This is no way to run a railroad.
 

Mand O'Lin

Singer of Songs Drinker of Drinks
No 500 ddo points again this month. Put in a ticket again. Got a reply that said they were aware of the problem and that the ticket is on hold. SMH
This is no way to run a railroad.
How can you tell you didn't get your points? Is there a log somewhere?
 

Mindos

CHAOTIC EVIL
I bought the vecna full bundle, but my receipt reads that I purchased a 12 month sub.

aug 16 2023
2441962897

I got the vecna bundle I payed for, just the receipt is wrong. Didn't really notice until now looking through my emails.

As others have stated, when the store changed over my Credit information was wrong or incomplete. I couldn't edit the entry and had to delete and reenter it. Since then the store has worked correctly.
 
We are working to resolve reports that some players have experienced a loss of their VIP subscription benefit after making a purchase of an expansion, and we need some specific cases to help us investigate.

If you ran into this issue after making an expansion purchase, please make sure you have a ticket in with Customer Support and then post your ticket number in this thread as a reply below.


We need to associate these forum reports with game accounts through our help system. Thanks!
The only issue I have come across is with the new store it seems not all the credit card information is staying stored as in the past. Specifically, the 3-digit security code is not saving properly. I had my VIP sub lapse but repurchased my VIP and had to manually input the 3-digit security code like when making a first-time purchase. So I would have the devs start with that code.
 

Cordovan

Community Manager
This thread relates to a specific issue that took place in August, and is not meant to be used as a general catch-all for queries to customer support. Closing this thread for timeliness and to prevent people from mistakenly posting in it. Please do reach out to CS for your account support needs.
 
Status
Not open for further replies.
Top