Need help with a very weird bug

Farenn

New member
I was hoping that either a fellow player or someone from SSG can help me with this. I have been playing this game for years without a problem. However recently (past couple days) when I play my melee oriented artificier all the sudden when I left click I am not longer able to attack any monsters. The same goes with trying to use anything in my characters hotbars, either by hitting my hotkeys or directly trying to click on them. The strange thing is that I am able to click the buttons on my hirelings bars, plus I can still fire my runearm by hitting its hotkey.

The only way I can fix this is by quickly logging out of the quest and then logging back in. However sometimes it does the same thing to me a short time later. This happened to me several months ago on another melee artificer. I was so frustrated and ended up deleting the character. All my other characters were just fine and I never experienced the bug again until recently. Has anyone else experienced losing the ability to attack or click on your characters hotbars? Any help would be appreciated because I am at a loss. Thanks.
 

GolargoSturdyfeet

Well-known member
Are you holding the shift key down? ie blocking? If so there is a bug that will lock up your alt. You can tumble to get out of it. Hope that helps.🤠
 

rabidfox

The People's Champion
Is it the result of hitting alt a bunch to fire your runearm? If you rebind the runearm fire button to something like "F" instead, does the problem stop?
 

calouscaine

Grouchy Vet
After the last 'maintenance' there has been a lot of odd things happening. I.e. toggles not working when they should together, the game alt tabbing out randomly, the game lag freezing, etc. My best suggestion is to wait for a hopeful fix next week. . .hopefully. If it doesn't occur, then register multiple complaints and bug reports. Take screen shots and document everything so that there might be a fix.
SSG seems to only do automated replies of late, so take screens, document, and report.
 

Tilomere

Well-known member
Try not charging your rune arm. Fuzzy memory suggests a memory leak related to changing stats due to BE cores as your runearm charges up and down continuously, and also that the cores are bugged somehow stat wise as well.

Also try the new block-free tumbling to reset animations. Blocking with runearm may break.
 
Last edited:

Farenn

New member
I don't do as much blocking as I probably should so I don't think it is that. And I have my rune arm bound to the ctrl key. However I have been using my rune arm a lot. I will try your suggestions about using the block free tumbling and also see if not charging the rune arms helps. Thank you all for the suggestions, I really appreciate it. At least I have somewhere to start with trying to figure this out. Worst case scenario I will file bug reports like calouscaine suggested if the problem is not resolved.
 

Farenn

New member
Hi everyone. I wanted to report back that I had some success. I was playing a quest and the bug happened to me twice. So I tried to tumble with the new tumbling feature toggled on like Tilomere suggested and it worked! I was able to attack again. Then later I had the same problem happen and once again a quick tumble took care of the problem. One the second quest I was curious if the new tumble feature had to be toggled on for this to work. So, I unchecked the box and started playing. Sure enough I encountered the bug again and the normal style of tumbling also worked. Again, thank you all for your help! While it is annoying that this bug exists, at least I have a very quick fix for it.
 
Top