You can launch the game if you skip the patcher - non sketchy method

iLuvGoat

Member
UPDATE! The patcher is fixed! We can all remove the -disablepatch command line argument fix






FYI for support for our community: making a new post so that hopefully people can find this without going through a multiple page thread.

This doesn't use any third party apps, but instead uses available info from the Wiki concerning executable command line arguments.


Right click your DDO shortcut, or create a new one to DNDLauncher.exe

SOCzIBQ.png


Then, in the Target line, make sure to add in the flag -disablepatch then Apply / Save. Make sure to Run as Admin

Mine looks like this:

"F:\Games\Steam Games\steamapps\common\Dungeons and Dragons Online\DNDLauncher.exe" -disablepatch

But yours may look like: "C:\Promgrams Files (x86)\StandingStoneGames\Dungeons and Dragons Online\DNDLauncher.exe" -disablepatch


RJZlPCt.png


You will need to run the shortcut as an Admin. You can do this by right-clicking the newly modified shortcut and choosing the 'Run as Administrator' option or right-click -> go to Properties, click on Advanced, then check the box for Run As Administrator

F7A02nu.png


Again: not a hack or sketchy etc., just using built-in executable arguments that the company provides. No risk here.


**special note** once SSG fixes their patcher, please remember to remove this -disablepatch command line argument we use in our shortcut.


UPDATE! The patcher is fixed! We can all remove the -disablepatch command line argument fix
 
Last edited:

qrenx1

New member
FYI for support for our community: making a new post so that hopefully people can find this without going through a multiple page thread.

This doesn't use any third party apps, but instead uses available info from the Wiki concerning executable command line arguments.


Right click your DDO shortcut, or create a new one to DNDLauncher.exe

Then, in the Target line, make sure to add in the flag -disablepatch then Apply / Save. Make sure to Run as Admin

Mine looks like this:

"F:\Games\Steam Games\steamapps\common\Dungeons and Dragons Online\DNDLauncher.exe" -disablepatch

But yours may look like: "C:\Promgrams Files(x86)\StandingStoneGames\Dungeons and Dragons Online\DNDLauncher.exe" -disablepatch

You will need to run the shortcut as an Admin. You can do this by right-clicking the newly modified shortcut and choosing the 'Run as Administrator' option or right-click -> go to Properties, click on Advanced, then check the box for Run As Administrator

Again: not a hack or sketchy etc., just using built-in executable arguments that the company provides. No risk here.
Worked for me. Thank you and good questing.
 

AllWrong74

New member
This worked like a charm, thanks!

FYI, if you run the game from Steam, you can right-click the game in steam, go to properties, the enter -diisablepatch in the launch options line. You don't have to edit the shortcut. Just remember to remove it once the patcher is working again, or you won't receive patches, anymore.
 

iLuvGoat

Member
This worked like a charm, thanks!

FYI, if you run the game from Steam, you can right-click the game in steam, go to properties, the enter -diisablepatch in the launch options line. You don't have to edit the shortcut. Just remember to remove it once the patcher is working again, or you won't receive patches, anymore.

Great tip!
 

rabidfox

The People's Champion
I always forget about the launcher commands until issues pop up like the patch server being down. Thanks for the reminder.
 

Therminator

New member
Yes, this worked for me! Thank you

I did have to use this instead (includes a space before "(x86)"):
"C:\Program Files (x86)\StandingStoneGames\Dungeons & Dragons Online\DNDLauncher.exe" -disablepatch
 
Last edited:

Driaza

Well-known member
Sigh - thought it was just me and did the whole flush dns, repair, reinstall and now the above does not work as i guess i have a fresh copy and do need to patch it before it runs

there goes my evening!
 

MoonJB

Member
For all the Mac users out there, this worked for me (this pre-supposes you're using Crossover to run the launcher):
1. Open the Crossover folder.
2. Right-click on the DDO Launcher and select Run with Options...
3. In "Command-Line Options:", which is blank, type -disablepatch.
4. Click the Run button and off you go.
 

jsvalera83

New member
worked for me too, awesome thank you. I feel that this needs to be sticky post. and someone at Standing Stone need to put the walk around on the launcher so everybody can see it.
 

Melkizadek

Active member
DIdn't work for me. I have been out of town for a week and when it loads in it says I don't have the current version of the client installed.
 

Mand O'Lin

Singer of Songs Drinker of Drinks
For all the Mac users out there, this worked for me (this pre-supposes you're using Crossover to run the launcher):
1. Open the Crossover folder.
2. Right-click on the DDO Launcher and select Run with Options...
3. In "Command-Line Options:", which is blank, type -disablepatch.
4. Click the Run button and off you go.
That did not work for me, I just ended up with a blank screen.

However, saving the launch command (with the -disablepatch) as a new launcher item did work.
 
Top