DDO debugging issues (as crowdsourced by many players advice)

rabidfox

The People's Champion
There's a bunch of issues people run into when 1st starting (or returning to DDO) that we run into all the time over on DDO discord and we've come up with a bunch of basic checklist type things to do when having problems. It'd be nice if SSG fixed some of these problems but until then here's various things to do when having issues.

Account creation:
Try a different email address (it doesn't like some email addresses)
If you get an error, trying using a basic password. Like silly basic, like the kind of bad password your parents would use with only letters and numbers; change it to something more secure afterwards (this has worked a bunch for people who couldn't create an initial DDO account).

Things you can try if the game isn't launching or having other issues (Crashing, video stuttering #10 can be a big cause of that):
1) Don'tuse the Steam launcher (you can also bypass steam if you downloaded using it by searching for DNDlauncher.exe on your computer and running it directly).
2) Use 64-bit client (launcher > options > general tab> 64-bit) (forcing it to 32-bit might also help some people) (gotta love opposing advice but old games play silly like that)
rmtB6Th.png

Ag70KrD.png

3) Download old directx libraries: https://www.microsoft.com/en-us/download/details.aspx?id=35 (be sure to unclick the install bing toolbar install option)
or https://www.microsoft.com/en-us/download/details.aspx?id=8109 (this version may be the better choice for people or just try both versions to insure best odds one of them gets things installed correctly as Windows + Old things like DX9 libraries can be a pain). This version extracts a bunch of files onto your computer, put them in a folder that's easy to find like on your desktop, then open that folder and run DXSETUP as admin.
4) Check your firewall and antivirus (quarantine) if they block the game all of the sudden
5) Run as admin as a quick check for permissions. Run with caution.
6) log into a different server than the last
7) Clear your DNS
8) No joke - unplug all your usb devices, restart your pc and try to launch the game
9) Use an alternative launcher: https://ddowiki.com/page/Launcher#Alternate_launchers
10) Make sure your graphics card is selected. (launcher > options > repair tab> your video card)
lTsvLFp.png

11) Update the .Net framework
12) Turn off your game's audio (recent OpenAL driver work can cause issues for some people)
13) try turning off 3rd party software's overlays (like geforce experience's overlays, discord's overlays, steams's, etc.)
14) try this alternative method for installing directX and .NET files:
Xaerxiessia said:
this the DirectX enduser runtimes I used to build a Win7 with Simplix update pack
https://www.wincert.net/forum/topic/12622-microsoft-directx-end-user-runtimes-june-2010
it's a .WA package meant to be integrated along vc_redist & .NET framework 4.8 and it's working very fine.
https://www.sevenforums.com/installation-setup/415754-update-your-win-7-installation-media.html
 
Last edited:

rabidfox

The People's Champion
15) turn off onedrive (it can cause the game's userpref file to get reset)
16) If you're getting weird game resolution settings, try changing your DPI:

compatibility mode > change high DPI settings and turn the 2 tick boxes on so that it allows DDO to set its own DPI scale instead of using windows one (this was in Windows 11, might be different in other versions of Windows)
MkeayJY.png


or try this setting instead (as results for what setting works best may vary from system to system)

OQrmzwx.png


17) Try changing exlusive mode for your audio.
Xaerxiessia said:
In Windows , you may tune the Exclusive mode in the Advanced Panel of your Playback Device Properties dialog-box (right click sound icon in the tray for playback devices to open the dialogbox with a list or active / inactive devices , in Win7 but should be mostly the same in W10 or above).
you should give Applications Priority to Exclusive Mode. This can be jammed if you start DDO with Administrators' Rights so you should not.

There's an option in the sound settings in DDO that disable sound for playback on focus loss. that may help.

Also , some applications able to freeze and lock low-level access to the sound-card , thus disabling all sounds , Audacity is notorious for that in case of multi-tracks project.
W60c1jc.png

18) Try adjusting settings under options>troubleshoot. Capping frame rates at 60 may help some people. Adjustting engine speed up or down may also help.
judjJ26.jpg

19) Can try replacing OpenAL version used by the game if having audio crashes/sound issues.
From the other thread:

I found a solution to this problem on the DDO discord. Replacing the the OpenAL32.dll files in the DDO directory fixed my crashing.

Steps:
1. Go to https://openal-soft.org/
2. Download the Win32 and Win64 Binary zip file (openal-soft-1.23.0.bin.zip)
3. Extract files
4. Copy openal-soft-1.23.0.bin\router\win32\OpenAL32.dll to the base "Dungeons and Dragons Online" directory
5. Copy openal-soft-1.23.0.bin\router\win64\OpenAL32.dll to "Dungeons and Dragons Online\x64" directory

This will need to be redone after every patch.
20) if you have a Msvcr100.dll error, try installing Visual C++ files from https://www.microsoft.com/en-us/download/details.aspx?id=26999
21) if the patch server is down:
Add -disablepatch to the end of DND launcher in a shortcut to the app. Be sure to run as admin when launching. Info from https://forums.ddo.com/index.php?th...you-skip-the-patcher-non-sketchy-method.4474/
Addtional launcher commands can be found here: https://ddowiki.com/page/Launcher
4hWmJSL.png

MZ5KLkt.png

22) Try using a VPN. Occasionally people have network issues between their home and SSG's servers which using a VPN reroutes the network traffic around the problem.
 
Last edited:

PraetorPlato

Well-known member
Any suggestions for intermittent (50% of time or so) crash on zone into Wynwood hall (as soon as you take a step forward), midway up the slope in Tanaora, and on some loading screens?

Playing on 32 bit client, Windows 11 through parallels on Mac M1 hardware. I've already tried 1, can't try 2, tried 3, 4, 5, 6, 8, 10.
 

rabidfox

The People's Champion
Windows 11 through parallels on Mac M1 hardware.
I don't personally know fixes for mac's using parallels. I know there's people over on discord who've helped people on macs and linux before but I don't know off-hand what all worked/didn't work and we didn't have any of that advice pinned (we just had the most common issues that come up all the time pinned). If anyone here or discord helps you solve it, or if you find a solution yourself, I'll add it to the advice above.
 

rabidfox

The People's Champion
Fixed the issue

(tumbling did not work either)

I checked almost everything - including updating DX, tried using DX9, 10, but then went back to DX11.
Reinstalled Game
Reinstalled NVideo drivers

After reinstalling the video/and geforce experience, i decided to disable the Game Overlay, I don't use it.
That seemed to do the trick. The game is operating normally, and i do not seem to be experiencing the super lag others are reporting.

The problem i had was not lag, the game was not working at all.

Hope this helps someone else.
Added turning off 3rd party software's overlays to the intial post as something people can try if having issues; thanks to this post about geforce experience's overlays causing a problem.
 

sebastianosmith

New member
Any suggestions for intermittent (50% of time or so) crash on zone into Wynwood hall (as soon as you take a step forward), midway up the slope in Tanaora, and on some loading screens?

Playing on 32 bit client, Windows 11 through parallels on Mac M1 hardware. I've already tried 1, can't try 2, tried 3, 4, 5, 6, 8, 10.
I run DDO with WINE on Arch Linux and have encountered a very similar issue. According to the WINE logs it's an audio driver crash in almost every instance - an invalid memory handle by the looks of it. Turning off game sound has mostly stopped the crashing, and prompted me to throw Windows on a spare drive ;).
 

PraetorPlato

Well-known member
I run DDO with WINE on Arch Linux and have encountered a very similar issue. According to the WINE logs it's an audio driver crash in almost every instance - an invalid memory handle by the looks of it. Turning off game sound has mostly stopped the crashing, and prompted me to throw Windows on a spare drive ;).
Ugh, ok. I LIKE sound (but maybe I like stability more....)
 

Xaerxiessia

Well-known member
In Windows , you may tune the Exclusive mode in the Advanced Panel of your Playback Device Properties dialog-box (right click sound icon in the tray for playback devices to open the dialogbox with a list or active / inactive devices , in Win7 but should be mostly the same in W10 or above).
you should give Applications Priority to Exclusive Mode. This can be jammed if you start DDO with Administrators' Rights so you should not.

There's an option in the sound settings in DDO that disable sound for playback on focus loss. that may help.

Also , some applications able to freeze and lock low-level access to the sound-card , thus disabling all sounds , Audacity is notorious for that in case of multi-tracks project.
 

Neain

Well-known member
Is there a fix for in-game voice chat not getting high enough to hear over any other sounds?
All my other ddo sounds can go plenty high to hear them (some a bit too high. GM audio) but ddo voice even with all the settings related to it at max, will get drowned out by even just having Pandora on in the background or a car going past outside or even my cat meowing from closer than 10 ft away.
 

rabidfox

The People's Champion
Is there a fix for in-game voice chat not getting high enough to hear over any other sounds?
All my other ddo sounds can go plenty high to hear them (some a bit too high. GM audio) but ddo voice even with all the settings related to it at max, will get drowned out by even just having Pandora on in the background or a car going past outside or even my cat meowing from closer than 10 ft away.
I personally use 2nd set of speakers. I have the game (and windows in general) use one audio output for game sounds (onboard motherboard audio) and I output voice (both the game's and discord's) to another (via nivida audio and monitor's speaker jack). This lets me fine tune things, on the fly, in ways I couldn't do in-game. I'd be curious myself if someone has a better solution.
 

rabidfox

The People's Champion
Thank you for the guide. I saw another related post and your reply to that as well. There is a new binary release (1.23.1) in case you want to update the post.
Steps:
1. Go to https://openal-soft.org/
2. Download the Win32 and Win64 Binary zip file (openal-soft-1.23.0.bin.zip)
3. Extract files
4. Copy openal-soft-1.23.0.bin\router\win32\OpenAL32.dll to the base "Dungeons and Dragons Online" directory
5. Copy openal-soft-1.23.0.bin\router\win64\OpenAL32.dll to "Dungeons and Dragons Online\x64" directory

This will need to be redone after every patch.
There's a new 1.23.1 version of OpenAL available. For anyone with raptor audio issues that tries it, please report if it works better/worse/same as 1.23.0 for dealing crashes for you.
 

Ayekin

Member
There's a new 1.23.1 version of OpenAL available. For anyone with raptor audio issues that tries it, please report if it works better/worse/same as 1.23.0 for dealing crashes for you.

Just reporting in. I haven't been very scientific about my testing but I had lots of trouble due to the raptors in Smash and Burn in the Cogs.

It crashed without an official patch since last I replaced the 1.23.1 binaries.
I replaced the binaries, launched the launcher (did a small file check/download thing), and crashed again.
I launched the launcher (no file check bit), replaced the binaries, and then started the game. Went through the entire thing and punched all the dumb raptors in their dumb faces without crashing.

I think the launcher knows those binaries are not the originals and does a quick replacement. I tried making them read-only but that didn't work either. Is there any setting to stop the launcher from auto-verifying and replacing the binaries?
 

rabidfox

The People's Champion
Just reporting in. I haven't been very scientific about my testing but I had lots of trouble due to the raptors in Smash and Burn in the Cogs.

It crashed without an official patch since last I replaced the 1.23.1 binaries.
I replaced the binaries, launched the launcher (did a small file check/download thing), and crashed again.
I launched the launcher (no file check bit), replaced the binaries, and then started the game. Went through the entire thing and punched all the dumb raptors in their dumb faces without crashing.

I think the launcher knows those binaries are not the originals and does a quick replacement. I tried making them read-only but that didn't work either. Is there any setting to stop the launcher from auto-verifying and replacing the binaries?
Someone made a batch file to automate the process. https://forums.ddo.com/index.php?threads/raptor-sounds-crash-your-ddo-client-fix-inside.3157/ Use at your own risk and/or edit it to fit your needs (I haven't looked at the batch file itself).
 

Ayekin

Member
Someone made a batch file to automate the process. https://forums.ddo.com/index.php?threads/raptor-sounds-crash-your-ddo-client-fix-inside.3157/ Use at your own risk and/or edit it to fit your needs (I haven't looked at the batch file itself).

The batch file is pretty simple. Per the poster's instructions, you need to edit the first two lines for your own install location.

The following two blocs just delete the OpenAL32.dll file and copy/rename the provided (working) DLL files in its place. The rub is you have to run the batch file between opening the launcher and launching the game, but at least you don't have to move the files in manually.
If you wanna be super safe you can just replace the provided DLLs with the ones you download yourself from the openal site.
 

rabidfox

The People's Champion
Add alternative setting for high DPI that played nicer for another person as per their instructions here:

OQrmzwx.png
 

rabidfox

The People's Champion
FYI for support for our community: making a new post so that hopefully people can find this without going through a multiple page thread.

This doesn't use any third party apps, but instead uses available info from the Wiki concerning executable command line arguments.


Right click your DDO shortcut, or create a new one to DNDLauncher.exe

Then, in the Target line, make sure to add in the flag -disablepatch then Apply / Save. Make sure to Run as Admin

Mine looks like this:

"F:\Games\Steam Games\steamapps\common\Dungeons and Dragons Online\DNDLauncher.exe" -disablepatch

But yours may look like: "C:\Promgrams Files(x86)\StandingStoneGames\Dungeons and Dragons Online\DNDLauncher.exe" -disablepatch

You will need to run the shortcut as an Admin. You can do this by right-clicking the newly modified shortcut and choosing the 'Run as Administrator' option or right-click -> go to Properties, click on Advanced, then check the box for Run As Administrator

Again: not a hack or sketchy etc., just using built-in executable arguments that the company provides. No risk here.
Adding info for if the patch server is down.
 
Last edited:
Top